Alter Aeon Community Forum
June 04, 2020, 07:18:20 am *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Registration is enabled!  Please register using the name of your primary character in-game.
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Alter Aeon Launcher for current Linux Distros  (Read 109 times)
Jarid
Newbie
*
Posts: 2


View Profile
« on: May 16, 2020, 11:12:31 am »

Hello Dentin,

I recently updated my Debian to v11 (bullseye) and found that the Alter Aeon client no longer works. It needs the libpng12 library that is no longer supported by actual Linux distros.

Is there a possibility that you can recompile the program for current versions?

Best regards,
Jarid
Logged
Jarid
Newbie
*
Posts: 2


View Profile
« Reply #1 on: May 18, 2020, 01:42:33 pm »

I found a solution that worked for me with Debian 11 (bullseye) on an amd64 system.
  • download libpng12
  • unpack deb archive (e.g. midnight commander or ar x <file>)
  • copy all from CONTENTS/lib/x86_64-linux-gnu to /usr/lib/x86_64-linux-gnu

I suggest to move AlterAeonLauncherLinux64.bin to /usr/local/games and create a symbolic link in /usr/local/bin.

Jarid
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2006-2008, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.099 seconds with 17 queries.